This project is read-only.

Execute PS Script Success status no script results

Apr 11, 2012 at 5:53 AM

I am using SCO 2012 with Execute PS Script.

If I run the Runbook I get a success status but the command does not really do anything.

If I run the Runbook Tester the PS Script 01 shows the script as

$LDAPdomain = [ADSI]('LDAP://Server01:636/CN=,CN=Users,CN=ExternalUsers,DC=perkins-group,DC=net')

If I run the script in powershell it sets the password for the user, but from the runbook I get the success status but the password is never set

Any thoughts on this

Apr 19, 2012 at 1:23 AM
Edited Apr 19, 2012 at 1:43 AM

I am seeing something very similar to this. Some of our previous (Opalis 6.3) activities that were imported into Orchestrator (2012 RTM) are running fine, but any new ones we create don't seem to return data back. One example is the Get-QADGroupMember cmdlet seems to always return a result count of 0 and results of null when run through the activity. In the Powershell command line it works fine for the exact same command and returns a few group members. Are we just missing something here? Our script is simply:

Add-PSSnapin Quest.ActiveRoles.ADManagement;Get-QADGroupMember 'domain\groupname' -Type 'user' -Indirect

Thanks in advance for any ideas!

Apr 20, 2012 at 7:00 PM

So we ended up using a command-line Activity that calls Powershell and the cmdlet instead, and it worked fine. Not sure why it doesn't work with the Powershell Activity.

Nov 8, 2013 at 7:56 PM
I am getting the same issue as you. Did you ever resolve it?